Rails - install Gem PG, can't find libpq-fe.h header

This is my experience long time ago. When I install Gem PG , one of rubygems to connect with PostgreSQL database, it said that "Can't find the 'libpq-fe.h header". The complete logs can be shown below.

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/home/user/.rvm/rubies/ruby-1.9.2-p320/bin/ruby extconf.rb 
checking for pg_config... no
No pg_config... trying anyway. If building fails, please try again with
 --with-pg-config=/path/to/pg_config
checking for libpq-fe.h... no
Can't find the 'libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
 --with-opt-dir
 --without-opt-dir
 --with-opt-include
 --without-opt-include=${opt-dir}/include
 --with-opt-lib
 --without-opt-lib=${opt-dir}/lib
 --with-make-prog
 --without-make-prog
 --srcdir=.
 --curdir
 --ruby=/home/user/.rvm/rubies/ruby-1.9.2-p320/bin/ruby
 --with-pg
 --without-pg
 --with-pg-dir
 --without-pg-dir
 --with-pg-include
 --without-pg-include=${pg-dir}/include
 --with-pg-lib
 --without-pg-lib=${pg-dir}/lib
 --with-pg-config
 --without-pg-config
 --with-pg_config
 --without-pg_config


Gem files will remain installed in /home/user/.rvm/gems/ruby-1.9.2-p320@THL/gems/pg-0.14.0 for inspection.
Results logged to /home/user/.rvm/gems/ruby-1.9.2-p320@THL/gems/pg-0.14.0/ext/gem_make.out
An error occurred while installing pg (0.14.0), and Bundler cannot continue.
Make sure that `gem install pg -v '0.14.0'` succeeds before bundling.

After doing a little research on the internet, I found the following way can solve it: - Install libpq-dev for Ubuntu systems. - Install postgresql-devel on RHEL systems. To be more clear, for Ubuntu users (I'm Ubuntu user) , just run :

sudo apt-get install libpq-dev

Insert the password as usual and wait until the process is compleate. Make sure you're connected to internet before doing this.